Дисконект вьювера от сервера

Вопросы, связанные с эксплуатацией, тестированием и лицензированием LiteManager - программы удаленного управления и администрирования компьютеров.

Re: Дисконект вьювера от сервера

Сообщение admin » 21 июн 2011, 13:54

ок, на неделе выйдет обновление, надеюсь проблема с разрывами исчезнет, у нас в ходе тестирования данная проблема не возникает.
С уважением LiteManagerTeam

support@litemanager.ru
+7 909 424 80 31
Icq: 615906065
Skype: LiteManagerTeam
admin
Администратор
 
Сообщения: 4262
Зарегистрирован: 02 июн 2010, 13:59

Re: Дисконект вьювера от сервера

Сообщение Serggg » 29 июн 2011, 09:42

версия 4,3,2 дисконект на месте. Правда теперь предлагает переподключится , при нажатии "да" само переподключается.

Но есть по этому поводу одно соображение, более детально протестю отпишусь. В двух словах - замечено что периодически (в подключеном режиме) прога (сервер) делает конект loopback на порт 5650 , и обратно тоже на этот же порт , т.е. создается два подключение IN и OUT , так вот если закрыть это соединение конект рвется и как раз по авторизации. А если вообще запретить loopback 5650 то и вообще не подключишься. Так вот мне кажется что как раз бывает (толи от загружености или ...) loopback не проходит и идет дисконект ....
Serggg
 
Сообщения: 77
Зарегистрирован: 02 мар 2011, 15:10

Re: Дисконект вьювера от сервера

Сообщение admin » 29 июн 2011, 11:21

интересная ситуация, Сервер по сути вообще не должен с кем то соединятся.
Но это возможно либо в случае настроенного Обратного соединения или Соединения по ID, а так же в случае если сервер используется в каскадном подключение.

Очень похоже на каскадное подключение, Вьювер соединяется с сервером а сервер в свою очередь должен установить соединение далее с другим сервером. Включите логирование в настройках сервера тогда в логах должны появится записи о каскадном подключение.
С уважением LiteManagerTeam

support@litemanager.ru
+7 909 424 80 31
Icq: 615906065
Skype: LiteManagerTeam
admin
Администратор
 
Сообщения: 4262
Зарегистрирован: 02 июн 2010, 13:59

Re: Дисконект вьювера от сервера

Сообщение Serggg » 29 июн 2011, 11:36

Ситуация такая
сервер настроен через обратное соединение на noip (У меня все машины настроены через свой noip, кот. имеет доступ внутри локалки так и в инет проброшен порт, что бы я мог на любую машину попасть с любого места) . На одной из машин (переносной ноут, который подключается с разных мест) стоит аутпост. В аутпосте создал правило пускать все на внешний ИП noip. На эту машыну установил сервер прописал обратное соединение (ИД и внешний апишник noip сервера) - сервер подключился к noip. Пытаюсь подключиться к машине - неа, говорит не найдена. Отключаю аутпост - подключился к машине. Включаю аутпост мониторю, вижу что в момент подключения сервер соединяется сам на себя по loopback в два конекта( один как IN другой OUT) буквально на 5-10 сек. Через определенное время опять появляются loopback...прописал правило и все заработало.

Так были сделаны выше написаные выводы.
Serggg
 
Сообщения: 77
Зарегистрирован: 02 мар 2011, 15:10

Re: Дисконект вьювера от сервера

Сообщение admin » 29 июн 2011, 12:33

Включаю аутпост мониторю, вижу что в момент подключения сервер соединяется сам на себя по loopback в два конекта( один как IN другой OUT) буквально на 5-10 сек. Через определенное время опять появляются loopback...прописал правило и все заработало.

Да, так и есть.
Когда устанавливается обратное соединение создается два канала передачи данных, один к самому себе на 127.0.0.1, другой к NoIP.
Думаю проблем при подключение к 127.0.0.1 не должно быть из за нагруженности канала, поэтому связь может разрываться если не удастся подключится к NoIP, возможно при неудачно подключение связь полностью обрывается, проверю этот момент в ближайшее время.
С уважением LiteManagerTeam

support@litemanager.ru
+7 909 424 80 31
Icq: 615906065
Skype: LiteManagerTeam
admin
Администратор
 
Сообщения: 4262
Зарегистрирован: 02 июн 2010, 13:59

Re: Дисконект вьювера от сервера

Сообщение Serggg » 29 июн 2011, 12:48

admin писал(а):Думаю проблем при подключение к 127.0.0.1 не должно быть из за нагруженности канала


тут канала вообще не надо, у меня обрывы с машиной в 1гбит локалке, речь шла о загружености машины. Тут смущает то, что соединение на 127,0,0,1 оно не постоянное , а временное с определенным интервалом, вот периодически и не проходит это соединение.

Но это всего лишь догадки..решать и проверять Вам, я всего лишь помогаю.
Serggg
 
Сообщения: 77
Зарегистрирован: 02 мар 2011, 15:10

Re: Дисконект вьювера от сервера

Сообщение admin » 29 июн 2011, 13:12

тут канала вообще не надо, у меня обрывы с машиной в 1гбит локалке, речь шла о загружености машины. Тут смущает то, что соединение на 127,0,0,1 оно не постоянное , а временное с определенным интервалом, вот периодически и не проходит это соединение.

Технически такое соединение необходимо. Но проходить оно должно все время, проверим эту часть кода.
Может файрволл блокирует?
С уважением LiteManagerTeam

support@litemanager.ru
+7 909 424 80 31
Icq: 615906065
Skype: LiteManagerTeam
admin
Администратор
 
Сообщения: 4262
Зарегистрирован: 02 июн 2010, 13:59

Пред.

Вернуться в LiteManager: Техническая поддержка, тестирование, неполадки и другие вопросы

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 7

cron